<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":7,"applicationTime":602,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='stage.guce.rivals.com' name='oath:guce:consent-host'>
<meta content='true' name='oath:guce:report-only'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81696975-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<title>BlueWhiteIllustrated  -  Steady Improvement Primes Dotson for Sophomore Season</title>
<meta content='BlueWhiteIllustrated  -  Steady Improvement Primes Dotson for Sophomore Season' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-d3bc3033f46244e09889e63a9371458b2358ecd46eec1bb4905f39f57a8b91cb.css" />


<script src="https://cdn.rivals.com/production/assets/lib-403e12296bc1d3b1a09dc124fff40ac8dba7b129893813e2b816e23db59490e1.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-3f037822045f2539f89c384da0aa38b8ef39cced7ee6d181ad50684c552b7a39.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="KfirTQgXJ8eucm2fpkrkmga5LfZsIUKDyjXTsLrrgXDxZZADty32uvko/igMbtk3E2i55ECNOxiP3upHPMyqEQ==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      var singleSiteApp = function() {
        return "false";
      };
  
      return {
        getPremiumIcon: getPremiumIcon,
        singleSiteApp: singleSiteApp
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://bwi.rivals.com/news/steady-improvement-primes-dotson-for-sophomore-season' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/v3dbmjcbzg9jqosrxpi5' property='og:image'>
<meta content='Jahan Dotson is primed for an even bigger performance in his sophomore campaign.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-08-23 06:54:16 -0500' property='article:published_time'>
<meta content='2019-08-23 06:54:17 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Jahan Dotson' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "bwi.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='bwi contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .bwi #programming > h1 {
      background-color: #00002F !important; } }
  .bwi .wrapper-container .team-colors-line {
    background-color: #2c5a97; }
  .bwi img.custom-premium-icon, .bwi .custom-premium-icon, .bwi img.custom-premium-white-icon, .bwi .custom-premium-white-icon,
  .bwi img.custom-premium-gallery-icon, .bwi .custom-premium-gallery-icon, .bwi .premium-icon-container {
    display: none; }
  .bwi .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #00002F; }
    .bwi .team-colors-line .color {
      width: 33.33%; }
    .bwi .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .bwi .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .bwi .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .bwi .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .bwi .team-colors-line.header {
      height: 6px; }
  .bwi > header .notification-link .count-container {
    background-color: #00002F !important; }
  .bwi > header .wrapper-container {
    background-color: #00002F !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .bwi > header .wrapper-container {
        border-bottom: 6px solid #2c5a97 !important; } }
  .bwi > header .invalid-email-banner {
    background-color: #00002F;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .bwi > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .bwi > header .invalid-email-banner a:hover {
      color: #2c5a97; }
  @media screen and (max-width: 767px) {
    .bwi > header .mobile-header {
      background-color: #2c5a97 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .bwi > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .bwi > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .bwi > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .bwi > header .nav-row > ul,
    .bwi > header .third-nav {
      background-color: white !important; }
    .bwi > header .dropdown-toggle > i.fa {
      color: #00002F !important; } }
  .bwi > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #00002F; }
  
  .site-primary-font-color {
    color: #00002F; }
  
  .site-primary-background-color {
    background-color: #00002F; }
  
  .site-secondary-font-color {
    color: #2c5a97; }
  
  .site-secondary-background-color {
    background-color: #2c5a97; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(0, 0, 47, 0.4), rgba(0, 0, 47, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #00002F;
    --secondary-color: #2c5a97;
    --accent-color: #00002F;
    --button-color: #00002F;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false,"BWI")' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Penn State" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://bwi.rivals.com/"><img src="https://res-2.cloudinary.com/rivals/image/upload/xw6zzd0nvjkgxqnnv6fg" alt="Xw6zzd0nvjkgxqnnv6fg" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath + ctrl.utmParams }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://bwi.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;bwi&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://bwi.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;bwi&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733079,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Steady Improvement Primes Dotson for Sophomore Season"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@BWIonRivals' name='twitter:site'>
<meta content='Steady Improvement Primes Dotson for Sophomore Season' name='twitter:title'>
<meta content='Jahan Dotson is primed for an even bigger performance in his sophomore campaign.' name='twitter:description'>
<meta content='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/v3dbmjcbzg9jqosrxpi5' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":113,"legacy_id":890,"name":"BlueWhiteIllustrated","friendly_name":"Penn State","annual_discount":null,"subdomain":"bwi","primary_color":"00002F","secondary_color":"2c5a97","font_color":"ffffff","short_name":"BWI","maple_ncaaf_team_id":34,"maple_ncaaf_endpoint":"ncaaf/teams/ppb","maple_ncaab_team_id":459,"maple_ncaab_endpoint":"ncaab/teams/paf","maple_college_id":34,"google_analytics_id":"UA-81696975-1"}, true, 252, nil, {"id":165,"primary_color":"00002F","secondary_color":"2c5a97","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"","header_logo_cloudinary":"xw6zzd0nvjkgxqnnv6fg","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81696975-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":false,"other_content":true,"site_id":113,"created_at":"2016-11-23T13:38:45.501-06:00","updated_at":"2019-01-14T19:00:00.872-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":2},{"active":false,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":null},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"forums_link_url":"https://bwi.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"5964f20b955a3163d7026909","aol_company_id":"595e95342a30cb7ee3e53952","ad_frequency":5,"display_twitter_follow":true,"display_fb_follow":true,"follow_twitter_handle":"BWIonRivals","follow_fb_handle":"BlueWhiteIllustrated","forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null,"custom_premium_icon_enabled":null,"email_logo_cloudinary":null},&#x000A;"5964f20b955a3163d7026909", "595e95342a30cb7ee3e53952", "rivals", 15000, false, {"id":43,"user_id":1095,"site_id":113,"updated_at":"2018-11-13T10:29:47.800-06:00","publisher_name":"Nate Bauer","first_name":"Nate","last_name":"Bauer","site_title":"Senior Editor","bio":"Is in his 14th year covering Penn State football and men&#x0027;s basketball for Blue White Illustrated. ","twitter_handle":"NateBauerBWI","image_url":"https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/nrrynfvdaxeor5kcw7pu","publisher_name_and_title":"Nate Bauer, Senior Editor","site_name":"BlueWhiteIllustrated","site_short_name":"BWI","has_edited_profile":true})'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":76,"image_id":2613491,"url":"https://psu.bncollege.com/","position":1,"site_id":113,"created_at":"2016-02-01T11:47:26.526-06:00","updated_at":"2019-07-18T10:23:41.709-05:00","image_url":"https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/t0rr2hy3tlabcxw8zcjg"}' class='ad-one'></rv-custom-ad>
<rv-custom-ad ad='{"id":80,"image_id":2605316,"url":"https://www.lions-pride.com/","position":2,"site_id":113,"created_at":"2016-02-02T10:17:14.757-06:00","updated_at":"2019-06-25T09:27:08.123-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/hturxvjwyrlapxpau6pg"}' class='ad-two'></rv-custom-ad>

<rv-forums ad-referer='https://bwi.rivals.com/news/steady-improvement-primes-dotson-for-sophomore-season' base-api-url='https://BWI.forums.rivals.com/' forums-url='https://bwi.forums.rivals.com' homepage='false' pub-ad='{"id":80,"image_id":2605316,"url":"https://www.lions-pride.com/","position":2,"site_id":113,"created_at":"2016-02-02T10:17:14.757-06:00","updated_at":"2019-06-25T09:27:08.123-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/hturxvjwyrlapxpau6pg"}' size='size' space-id='2022733079' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://bwi.rivals.com/news/steady-improvement-primes-dotson-for-sophomore-season/printable' site-name='BlueWhiteIllustrated'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-08-23 06:54:16 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2071543/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Steady Improvement Primes Dotson for Sophomore Season</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/nrrynfvdaxeor5kcw7pu'>
<span>
<span class='author-name'>
Nate Bauer
&bull;
</span>
<span class='type-sm'>BlueWhiteIllustrated</span>
<div class='type-sm'>
<a href='//twitter.com/NateBauerBWI' target='_blank'>@NateBauerBWI</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Senior Editor</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/NateBauerBWI'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
Is in his 14th year covering Penn State football and men's basketball for Blue White Illustrated. 
</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>In just eight games played as a true freshman, <a href="https://n.rivals.com/content/prospects/2018/jahan-dotson-35">Jahan Dotson</a> finished as the Nittany Lions’ fifth-leading receiver for the 2018 season, hauling in 13 passes for 203 yards. </p><p>Yet in a recent conversation with head coach James Franklin, Dotson reflected on his film from the onset of his Penn State career and described it as “embarrassing.”</p><p>“Last year just watching film of myself running my routes, it seemed like I'd round every route, just about. I couldn't make sharp cuts,” Dotson told reporters this week. “I'm just trying to perfect my route-running every single day and I'm getting better at it.”</p><p>Emboldened by an offseason of work that has included tireless attention to detail both in catching the ball as well as in improving his route running, Dotson anticipates even more for himself in the season ahead. </p><p>And Penn State’s coaches can attest to it.</p><p>“He is just so confident,” said Franklin this week. “He's just so smooth. He's got unbelievable, natural ball skills. He still obviously can use time in the weight room to get more explosive and get bigger, but now I think he's strong enough and explosive enough to be an every-down Big Ten receiver. </p><p>“The exciting thing for him is I still think there's a lot more in the tank from a development standpoint with him. He's very, very confident. He's got a really good understanding.”</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/v3dbmjcbzg9jqosrxpi5','https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto/v3dbmjcbzg9jqosrxpi5')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/v3dbmjcbzg9jqosrxpi5" alt="V3dbmjcbzg9jqosrxpi5" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Can Jahan Dotson become a prime target in the Nittany Lions' passing game in his sophomore season? (Ryan Snyder/BWI)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Working with Dotson in the spring and through the summer months, Penn State’s new receivers’ coach, <b>Gerad Parker,</b> has also seen the Pennsylvania product's improvements.<br></p><p>Not standing out in either size or strength in either direction, at 5-foot-11, 170 pounds, Dotson represents a medium-sized body that brings a plethora of desirable attributes to the table for a receiver. </p><p>“(He) has got an unbelievable feel for his body. To me, I think he does a great job of being very fluid, loose, you know, you could almost use the word silky,” Parker said this summer. "He knows his body, can control it, has great ball skills and can catch it in tight quarters, and beat you vertically. </p><p>“A lot we talked about with Han is to close that last 10 percent because sometimes he will glide too much. And if he learns how to close the line 10 percent of his game, I really think everybody here is going to be really, really, really impressed with who he can become as a player.”</p><p>Certainly, as the Nittany Lions’ preseason comes to a close and the first game of the season against Idaho nears, Penn State safeties’ coach <b>Tim Banks</b> can be counted among those who have been impressed with Dotson’s performance.</p><p>Counting his own players among those who have benefited from Dotson's play, and vice versa, the early indicators out of the preseason are that of an improved performance for the young receiver moving forward.</p><p>“It's a pretty good battle because he has elite quickness. I think he has elite ball skills,” said Banks. “He's definitely one of my favorite players. He doesn't say a lot. He just goes about his business. We can be physical with him and he gets right back up and goes back to the huddle. He doesn't say a whole lot, he lets his game speak for itself. </p><p>“I'm really expecting him to have a tremendous year. He's really worked hard and you can see it from his preparation in the offseason. You can see it now and he's making our safety room better and even our corners better.”</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wjprlpb7skx3udnatiku','https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto/wjprlpb7skx3udnatiku')">
<div class='image-container'>
<a href='https://bwi.rivals.com/news/penn-state-nittany-lions-fans-75-ecard-to-adidas-25-off-subscription' target='_blank'>
<img class="image-with-caption" src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wjprlpb7skx3udnatiku" alt="Wjprlpb7skx3udnatiku" />
</a>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>CLICK HERE FOR DETAILS!</figcaption>
</div>
</figure>
</div>
<div class='text-center'>
<rv-share-links print-url='https://bwi.rivals.com/news/steady-improvement-primes-dotson-for-sophomore-season/printable' site-name='BlueWhiteIllustrated'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='{"id":80,"image_id":2605316,"url":"https://www.lions-pride.com/","position":2,"site_id":113,"created_at":"2016-02-02T10:17:14.757-06:00","updated_at":"2019-06-25T09:27:08.123-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/hturxvjwyrlapxpau6pg"}' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='false' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' site='{"id":113,"legacy_id":890,"name":"BlueWhiteIllustrated","friendly_name":"Penn State","annual_discount":null,"subdomain":"bwi","primary_color":"00002F","secondary_color":"2c5a97","font_color":"ffffff","short_name":"BWI","maple_ncaaf_team_id":34,"maple_ncaaf_endpoint":"ncaaf/teams/ppb","maple_ncaab_team_id":459,"maple_ncaab_endpoint":"ncaab/teams/paf","maple_college_id":34,"google_analytics_id":"UA-81696975-1"}' twitter-feed='{"id":113,"site_id":113,"handle":"@BWIonRivals","list_name":"BWI","created_at":"2016-02-01T12:25:19.119-06:00","updated_at":"2017-03-22T11:47:37.125-05:00","hashtags":[],"usernames":["BWIonRivals","PennStateFball","GoPSUSports","PennStateMBB","PennStateMHKY"],"max_number":4}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://bwi.rivals.com/news/steady-improvement-primes-dotson-for-sophomore-season/printable' site-name='BlueWhiteIllustrated'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733079', 'https://bwi.rivals.com/news/steady-improvement-primes-dotson-for-sophomore-season');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Steady Improvement Primes Dotson for Sophomore Season";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("BWI", 2071543, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":76,"image_id":2613491,"url":"https://psu.bncollege.com/","position":1,"site_id":113,"created_at":"2016-02-01T11:47:26.526-06:00","updated_at":"2019-07-18T10:23:41.709-05:00","image_url":"https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/t0rr2hy3tlabcxw8zcjg"}' class='ad-one'></rv-custom-ad>
</div>
</div>

</div>
</main>
<footer>
<!-- t('footer.about_link', primary_host: primary_host) -->
<ul class='footer-links list-inline'>
<li>
<a href='/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='/news/member-services'>Help</a>
</li>
</ul>
<div class='logo-container'>
<div class='footer-logo'></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC<br/>© 2019 Verizon Media. All rights reserved.</div>
</footer>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733079",
    c7: "https://bwi.rivals.com/news/steady-improvement-primes-dotson-for-sophomore-season"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fbwi.rivals.com%2Fnews%2Fsteady-improvement-primes-dotson-for-sophomore-season&c5=2022733079&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
